<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Sarah Cooper Gets Her Own Netflix Comedy Special</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.showbizjunkies.com/xmlrpc.php" />
<link rel="icon" type="image/png" href="https://www.showbizjunkies.com/wp-content/uploads/2015/10/showbiz-favicon.jpg">

<title>Sarah Cooper Gets Her Own Netflix Comedy Special</title>
<meta name="description" content="Social media star Sarah Cooper will be headlining her own variety special on Netflix. &#039;Sarah Cooper: Everything’s Fine&#039; is expected to premiere this fall." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Sarah Cooper Gets Her Own Netflix Comedy Special" />
<meta property="og:description" content="Social media star Sarah Cooper will be headlining her own variety special on Netflix. &#039;Sarah Cooper: Everything’s Fine&#039; is expected to premiere this fall." />
<meta property="og:url" content="https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/" />
<meta property="og:site_name" content="ShowbizJunkies" />
<meta property="article:publisher" content="http://www.facebook.com/ShowbizJunkies" />
<meta property="article:published_time" content="2020-08-12T17:27:25+00:00" />
<meta property="og:image" content="https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="1200" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@https://www.twitter.com/becmur" />
<meta name="twitter:site" content="@becmur" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.showbizjunkies.com/#website","url":"https://www.showbizjunkies.com/","name":"ShowbizJunkies","description":"TV, Movies, Music, Celebs - We&#039;re Addicted to Entertainment","potentialAction":[{"@type":"SearchAction","target":"https://www.showbizjunkies.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/#primaryimage","inLanguage":"en-US","url":"https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper.jpg","width":800,"height":1200,"caption":"Netflix announces 'Sarah Cooper: Everything's Fine' (Photo Credit: Mindy Tucker)"},{"@type":"WebPage","@id":"https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/#webpage","url":"https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/","name":"Sarah Cooper Gets Her Own Netflix Comedy Special","isPartOf":{"@id":"https://www.showbizjunkies.com/#website"},"primaryImageOfPage":{"@id":"https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/#primaryimage"},"datePublished":"2020-08-12T17:27:25+00:00","dateModified":"2020-08-12T17:27:25+00:00","author":{"@id":"https://www.showbizjunkies.com/#/schema/person/0093618f37a87a0b68144ab43884b762"},"description":"Social media star Sarah Cooper will be headlining her own variety special on Netflix. 'Sarah Cooper: Everything\u2019s Fine' is expected to premiere this fall.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/"]}]},{"@type":["Person"],"@id":"https://www.showbizjunkies.com/#/schema/person/0093618f37a87a0b68144ab43884b762","name":"Rebecca Murray","image":{"@type":"ImageObject","@id":"https://www.showbizjunkies.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0443e1d61842b1a84eb14d933d36fcae?s=96&d=mm&r=pg","caption":"Rebecca Murray"},"description":"Journalist covering the entertainment industry for 21+ years, including 13 years as the first writer for About.com's Hollywood Movies site. Member of the Broadcast Television Journalists Association, Broadcast Film Critics Association, Alliance of Women Film Journalists, and President of the San Diego Film Critics Society.","sameAs":["https://twitter.com/https://www.twitter.com/becmur"]}]}</script>

<link rel="amphtml" href="https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/amp/" /><meta name="generator" content="AMP for WP 1.0.57" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//plus.google.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//gstatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//google.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="ShowbizJunkies &raquo; Feed" href="https://www.showbizjunkies.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ShowbizJunkies &raquo; Comments Feed" href="https://www.showbizjunkies.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ShowbizJunkies &raquo; Sarah Cooper Gets Her Own Netflix Comedy Special Comments Feed" href="https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.showbizjunkies.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.showbizjunkies.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=db12099f894b3f53e301a89d22fdaaa5' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C300%7CRoboto%3A400%2C500%2C700%2C300&#038;display=swap&#038;ver=10.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.showbizjunkies.com/wp-content/themes/Newspaper/style.css?ver=10.3' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=db12099f894b3f53e301a89d22fdaaa5' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=d0cdd949f741c065e9b26cee76cd5ac2' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=bb9c459bd63f43ae3fb9edbc59eb20c6' type='text/css' media='all' />
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"100","ajax_url":"https:\/\/www.showbizjunkies.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"192013","token":"465e879429","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script>
<link rel='https://api.w.org/' href='https://www.showbizjunkies.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.showbizjunkies.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.showbizjunkies.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.showbizjunkies.com/?p=192013' />

<link rel="stylesheet" href="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/css/jd.gallery.css.php" type="text/css" media="screen" charset="utf-8" />
<link rel="stylesheet" href="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/css/jd.gallery.css" type="text/css" media="screen" charset="utf-8" />
<script type="text/javascript" src="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/scripts/mootools.v1.11.js"></script>
<script type="text/javascript" src="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/scripts/jd.gallery.js.php"></script>
<script type="text/javascript" src="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/scripts/jd.gallery.transitions.js"></script>


<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"465e879429","wpRestUrl":"https:\/\/www.showbizjunkies.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":20,"postAutoloadStatus":"on","origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.showbizjunkies.com\/wp-admin\/","wpRestNonce":"465e879429","wpRestUrl":"https:\/\/www.showbizjunkies.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
<style type="text/css"></style>
<style type="text/css">
.synved-social-resolution-single {
display: inline-block;
}
.synved-social-resolution-normal {
display: inline-block;
}
.synved-social-resolution-hidef {
display: none;
}

@media only screen and (min--moz-device-pixel-ratio: 2),
only screen and (-o-min-device-pixel-ratio: 2/1),
only screen and (-webkit-min-device-pixel-ratio: 2),
only screen and (min-device-pixel-ratio: 2),
only screen and (min-resolution: 2dppx),
only screen and (min-resolution: 192dpi) {
	.synved-social-resolution-normal {
	display: none;
	}
	.synved-social-resolution-hidef {
	display: inline-block;
	}
}
</style>

<script>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</script>

<style>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</style>

<script data-no-minify="1" async src="https://www.showbizjunkies.com/wp-content/cache/busting/1/gtm-9de5f771288940f7da00cc00e8cf27b3.js"></script>
<script>

  window.dataLayer = window.dataLayer || [];

  function gtag(){dataLayer.push(arguments);}

  gtag('js', new Date());

 

  gtag('config', 'UA-24192790-1');

</script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.showbizjunkies.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.showbizjunkies.com/category/celebrities/",
                    "name": "Celebrity News and Photos"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.showbizjunkies.com/category/celebrities/celebrity-news/",
                    "name": "Breaking Celebrity News"                                
                }
            }
            ,{
                "@type": "ListItem",
                "position": 4,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/",
                    "name": "Sarah Cooper Gets Her Own Netflix Comedy Special"                                
                }
            }    
        ]
    }
</script>

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #6f2882;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #6f2882;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #6f2882;
                }
                .tdm-btn-style1 {
					background-color: #6f2882;
				}
				.tdm-btn-style2:before {
				    border-color: #6f2882;
				}
				.tdm-btn-style2 {
				    color: #6f2882;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #6f2882;
                    -moz-box-shadow: 0 2px 16px #6f2882;
                    box-shadow: 0 2px 16px #6f2882;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #6f2882;
                    -moz-box-shadow: 0 4px 26px #6f2882;
                    box-shadow: 0 4px 26px #6f2882;
				}
</style>
<style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-192013 single-format-standard td-standard-pack sarah-cooper-everythings-fine global-block-template-1 single_template_10 td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>

<div class="td-menu-login-section">
<div class="td-guest-wrap">
<div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
</div>
</div>

<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-155904" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-155904"><a href="https://www.showbizjunkies.com/">Home</a></li>
<li id="menu-item-229" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-229"><a href="https://www.showbizjunkies.com/category/news/">Breaking News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-239" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li id="menu-item-241" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-241"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li id="menu-item-242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-242"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li id="menu-item-243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243"><a href="https://www.showbizjunkies.com/category/news/celebrities-news/">Celebs News</a></li>
</ul>
</li>
<li id="menu-item-1583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1583"><a href="https://showbizjunkies.com/category/movies/">Movies<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1420"><a href="https://www.showbizjunkies.com/category/movies/movies-reviews/">Latest Movie Reviews</a></li>
<li id="menu-item-236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li id="menu-item-2042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2042"><a href="https://www.showbizjunkies.com/category/movies/trailers/">New Movie Trailers</a></li>
<li id="menu-item-237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li id="menu-item-137687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137687"><a href="https://www.showbizjunkies.com/category/movies/best-of-lists/">Best Of Lists</a></li>
<li id="menu-item-1421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1421"><a href="https://www.showbizjunkies.com/category/movies/movies-interviews/">Movie Interviews</a></li>
<li id="menu-item-1422" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1422"><a href="https://www.showbizjunkies.com/category/movies/movies-clips/">Film Clips</a></li>
</ul>
</li>
<li id="menu-item-226" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-226"><a href="https://www.showbizjunkies.com/category/tv/">TV<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1419"><a href="https://www.showbizjunkies.com/category/tv/tv-recaps/">TV Show Recaps</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-231"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://www.showbizjunkies.com/category/tv/clips/">TV Show Clips</a></li>
<li id="menu-item-233" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-233"><a href="https://www.showbizjunkies.com/category/tv/interviews/">TV Interviews</a></li>
<li id="menu-item-234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-234"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
</ul>
</li>
<li id="menu-item-225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-225"><a href="https://www.showbizjunkies.com/category/music/">Music<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li id="menu-item-245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li id="menu-item-246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-246"><a href="https://www.showbizjunkies.com/category/music/music-videos/">Music Videos</a></li>
<li id="menu-item-248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-248"><a href="https://www.showbizjunkies.com/category/music/artists/">Music Artists &#8211; Album Details, Biographies and News</a></li>
</ul>
</li>
<li id="menu-item-155903" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-155903"><a href="#">Gallery<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1426"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
<li id="menu-item-1425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1425"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li id="menu-item-250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li id="menu-item-251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
</ul>
</li>
<li id="menu-item-255" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-255"><a href="https://www.showbizjunkies.com/category/celebrities/">Celebrity News and Photos<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-252" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-252"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-news/">Celeb News</a></li>
<li id="menu-item-253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-253"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
<li id="menu-item-1423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1423"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-videos/">Celeb Videos</a></li>
<li id="menu-item-105436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-105436"><a href="https://www.showbizjunkies.com/category/celebrities/celeb-interviews/">Celebrity Interviews &#8211; Actors, Writers and Directors</a></li>
<li id="menu-item-254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-info/">Celebrity Charities, Biographies, and Info</a></li>
<li id="menu-item-38296" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38296"><a href="https://www.showbizjunkies.com/category/celebrities/book-news/">Upcoming Book Releases and Book Reviews</a></li>
</ul>
</li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://www.showbizjunkies.com/">

<div class="td-search-close">
 <a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-1 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul></div>
<div class="td-header-sp-top-widget">
</div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.showbizjunkies.com/">
<img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Showbiz Junkies" title="Showbiz Junkies" data-lazy-src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" /><noscript><img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" alt="Showbiz Junkies" title="Showbiz Junkies"/></noscript>
<span class="td-visual-hidden">ShowbizJunkies</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_2ef td_block_template_1 ">
<style>
/* custom css */
.tdi_1_2ef.td-a-rec-img{
				    text-align: left;
				}.tdi_1_2ef.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="https://www.showbizjunkies.com/">
<img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Showbiz Junkies" title="Showbiz Junkies" data-lazy-src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" /><noscript><img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" alt="Showbiz Junkies" title="Showbiz Junkies"/></noscript>
</a>
<a class="td-header-logo td-sticky-disable" href="https://www.showbizjunkies.com/">
<img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Showbiz Junkies" title="Showbiz Junkies" data-lazy-src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" /><noscript><img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" alt="Showbiz Junkies" title="Showbiz Junkies"/></noscript>
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-155904"><a href="https://www.showbizjunkies.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-229"><a href="https://www.showbizjunkies.com/category/news/">Breaking News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-239"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-241"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-242"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-243"><a href="https://www.showbizjunkies.com/category/news/celebrities-news/">Celebs News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-1583"><a href="https://showbizjunkies.com/category/movies/">Movies</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1420"><a href="https://www.showbizjunkies.com/category/movies/movies-reviews/">Latest Movie Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-236"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2042"><a href="https://www.showbizjunkies.com/category/movies/trailers/">New Movie Trailers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-237"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-137687"><a href="https://www.showbizjunkies.com/category/movies/best-of-lists/">Best Of Lists</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1421"><a href="https://www.showbizjunkies.com/category/movies/movies-interviews/">Movie Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1422"><a href="https://www.showbizjunkies.com/category/movies/movies-clips/">Film Clips</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-226"><a href="https://www.showbizjunkies.com/category/tv/">TV</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1419"><a href="https://www.showbizjunkies.com/category/tv/tv-recaps/">TV Show Recaps</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-231"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-232"><a href="https://www.showbizjunkies.com/category/tv/clips/">TV Show Clips</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-233"><a href="https://www.showbizjunkies.com/category/tv/interviews/">TV Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-234"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-225"><a href="https://www.showbizjunkies.com/category/music/">Music</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-244"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-245"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-246"><a href="https://www.showbizjunkies.com/category/music/music-videos/">Music Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-248"><a href="https://www.showbizjunkies.com/category/music/artists/">Music Artists &#8211; Album Details, Biographies and News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-155903"><a href="#">Gallery</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1426"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1425"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-250"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-251"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children td-menu-item td-normal-menu menu-item-255"><a href="https://www.showbizjunkies.com/category/celebrities/">Celebrity News and Photos</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-252"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-news/">Celeb News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-253"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1423"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-videos/">Celeb Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-105436"><a href="https://www.showbizjunkies.com/category/celebrities/celeb-interviews/">Celebrity Interviews &#8211; Actors, Writers and Directors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-254"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-info/">Celebrity Charities, Biographies, and Info</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38296"><a href="https://www.showbizjunkies.com/category/celebrities/book-news/">Upcoming Book Releases and Book Reviews</a></li>
</ul>
</li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.showbizjunkies.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<article id="post-192013" class="td-post-template-10 post-192013 post type-post status-publish format-standard has-post-thumbnail category-celebrity-news category-news category-shows category-tv category-tv-news tag-maya-rudolph tag-natasha-lyonne tag-netflix tag-sarah-cooper td-container-wrap" itemscope itemtype="https://schema.org/Article">
<div class="td-video-template-bg">
<div class="td-container">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.showbizjunkies.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Celebrity News and Photos" class="entry-crumb" href="https://www.showbizjunkies.com/category/celebrities/">Celebrity News and Photos</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Breaking Celebrity News" class="entry-crumb" href="https://www.showbizjunkies.com/category/celebrities/celebrity-news/">Breaking Celebrity News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Sarah Cooper Gets Her Own Netflix Comedy Special</span></div></div>
<div class="td-post-featured-video">
</div>
</div>
</div>
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://www.showbizjunkies.com/category/celebrities/">Celebrity News and Photos</a></li><li class="entry-category"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-news/">Breaking Celebrity News</a></li><li class="entry-category"><a href="https://www.showbizjunkies.com/category/news/">Breaking News</a></li><li class="entry-category"><a href="https://www.showbizjunkies.com/category/tv/">TV</a></li><li class="entry-category"><a href="https://www.showbizjunkies.com/category/tv/shows/">Shows</a></li><li class="entry-category"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Sarah Cooper Gets Her Own Netflix Comedy Special</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.showbizjunkies.com/author/admin/">Rebecca Murray</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date">August 12, 2020</time></span> </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fsarah-cooper-everythings-fine%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Sarah+Cooper+Gets+Her+Own+Netflix+Comedy+Special&url=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fsarah-cooper-everythings-fine%2F&via=ShowbizJunkies">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/&amp;media=https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper.jpg&description=Social media star Sarah Cooper will be headlining her own variety special on Netflix. &#039;Sarah Cooper: Everything’s Fine&#039; is expected to premiere this fall.">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Sarah+Cooper+Gets+Her+Own+Netflix+Comedy+Special %0A%0A https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<figure id="attachment_192014" aria-describedby="caption-attachment-192014" style="width: 400px" class="wp-caption aligncenter"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20600'%3E%3C/svg%3E" alt="Sarah Cooper" width="400" height="600" class="size-large wp-image-192014" data-lazy-srcset="https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-400x600.jpg 400w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-200x300.jpg 200w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-768x1152.jpg 768w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-696x1044.jpg 696w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-280x420.jpg 280w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper.jpg 800w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-400x600.jpg" /><noscript><img src="https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-400x600.jpg" alt="Sarah Cooper" width="400" height="600" class="size-large wp-image-192014" srcset="https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-400x600.jpg 400w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-200x300.jpg 200w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-768x1152.jpg 768w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-696x1044.jpg 696w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper-280x420.jpg 280w, https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper.jpg 800w" sizes="(max-width: 400px) 100vw, 400px" /></noscript><figcaption id="caption-attachment-192014" class="wp-caption-text">Netflix announces &#8216;Sarah Cooper: Everything&#8217;s Fine&#8217; (Photo Credit: Mindy Tucker)</figcaption></figure>
<p>Social media star <a href="https://twitter.com/sarahcpr" rel="nofollow">Sarah Cooper</a> will be headlining her own variety special on Netflix. <em>Sarah Cooper: Everything&#8217;s Fine</em> is expected to premiere this fall and has actress/writer/director <a href="https://www.showbizjunkies.com/tag/natasha-lyonne/">Natasha Lyonne</a> (<em>Orange is the New Black</em>) attached to direct.</p>
<p><a href="https://www.showbizjunkies.com/tag/maya-rudolph/">Maya Rudolph</a> (soon to be super busy on <em>SNL</em>), Danielle Renfrew Behrens, and Lyonne will executive produce via their production company Animal Pictures. Cooper, Paula Pell, AGI Entertainment&#8217;s Chris Burns, and Irony Point&#8217;s Dan Powell are also attached as executive producers.</p>
<p>Cooper captured the attention of millions of TikTok and Twitter users &#8211; including celebs such as Chrissy Teigen, Cher, Bette Midler, and Lin-Manuel Miranda &#8211; with her lip-sync impressions of President Trump. She&#8217;s gained hundreds of thousands of followers with her &#8220;How to&#8230;&#8221; videos which she launched in April 2020. Her &#8220;How to Medical&#8221; video alone has been viewed more than 20 million times.</p>
<p>Before becoming a breakout social media star, Cooper was a writer and correspondent on CBS All Access&#8217; <em>Old News</em> pilot from producer Stephen Colbert. She&#8217;s also written the bestsellers <em>100 Tricks to Appear Smart in Meetings</em> and <em>How to be Successful Without Hurting Men&#8217;s Feelings</em>.</p>
<p><strong><em>Sarah Cooper: Everything&#8217;s Fine</em> Details, Courtesy of Netflix:</strong></p>
<p>&#8220;Best-selling author and comedian Sarah Cooper will bring her unique talent to Netflix with <em>Sarah Cooper: Everything’s Fine</em>, a variety special full of vignettes dealing with issues of politics, race, gender, class, and other light subjects. Sarah will be joined by a fantastic array of special guests who will participate in short interviews, sketches and more shenanigans.&#8221;</p>
<p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1475545870139320" data-ad-slot="7338398786" data-ad-format="autorelaxed"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<div id="amzn-assoc-ad-8664f0e8-95e2-484c-b072-743908c85ff3"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=8664f0e8-95e2-484c-b072-743908c85ff3"></script></div>

</div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.showbizjunkies.com/tag/maya-rudolph/">maya rudolph</a></li><li><a href="https://www.showbizjunkies.com/tag/natasha-lyonne/">natasha lyonne</a></li><li><a href="https://www.showbizjunkies.com/tag/netflix/">netflix</a></li><li><a href="https://www.showbizjunkies.com/tag/sarah-cooper/">sarah cooper</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe loading="lazy" frameBorder="0" src="about:blank" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.facebook.com/plugins/like.php?href=https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/&#038;layout=button_count&#038;show_faces=false&#038;width=105&#038;action=like&#038;colorscheme=light&#038;height=21"></iframe><noscript><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></noscript></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fsarah-cooper-everythings-fine%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Sarah+Cooper+Gets+Her+Own+Netflix+Comedy+Special&url=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fsarah-cooper-everythings-fine%2F&via=ShowbizJunkies">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/&amp;media=https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper.jpg&description=Social media star Sarah Cooper will be headlining her own variety special on Netflix. &#039;Sarah Cooper: Everything’s Fine&#039; is expected to premiere this fall.">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Sarah+Cooper+Gets+Her+Own+Netflix+Comedy+Special %0A%0A https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.showbizjunkies.com/tv/tough-as-nails-season-2-renewed/">&#8216;Tough as Nails&#8217; Will Stick Around for Season 2</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.showbizjunkies.com/tv/one-of-us-is-lying-series/">&#8216;One of Us Is Lying&#8217; Mystery Drama Ordered to Series at Peacock</a></div></div></div> <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.showbizjunkies.com/author/admin/">Rebecca Murray</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Rebecca Murray"></span><meta itemprop="datePublished" content="2020-08-12T13:27:25-04:00"><meta itemprop="dateModified" content="2020-08-12T13:27:25-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png"></span><meta itemprop="name" content="ShowbizJunkies"></span><meta itemprop="headline " content="Sarah Cooper Gets Her Own Netflix Comedy Special"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.showbizjunkies.com/wp-content/uploads/2020/08/sarah-cooper.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="1200"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_3_d00 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_3_d00"><script>var block_tdi_3_d00 = new tdBlock();
block_tdi_3_d00.id = "tdi_3_d00";
block_tdi_3_d00.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3_d00","td_column_number":3,"live_filter_cur_post_id":192013,"live_filter_cur_post_author":"1","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3_d00","tdc_css_class_style":"tdi_3_d00_rand_style"}';
block_tdi_3_d00.td_column_number = "3";
block_tdi_3_d00.block_type = "td_block_related_posts";
block_tdi_3_d00.post_count = "3";
block_tdi_3_d00.found_posts = "15456";
block_tdi_3_d00.header_color = "";
block_tdi_3_d00.ajax_pagination_infinite_stop = "";
block_tdi_3_d00.max_num_pages = "5152";
tdBlocksArray.push(block_tdi_3_d00);
</script><h4 class="td-related-title td-block-title"><a id="tdi_4_a3b" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3_d00" href="#">RELATED ARTICLES</a><a id="tdi_5_ccc" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3_d00" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3_d00 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.showbizjunkies.com/tv/magic-of-disney-animal-kingdom/" rel="bookmark" class="td-image-wrap" title="&#8216;Magic of Disney&#8217;s Animal Kingdom&#8217; Docuseries Offers a Peek Behind the Scenes"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" alt="Animal Kingdom" title="&#8216;Magic of Disney&#8217;s Animal Kingdom&#8217; Docuseries Offers a Peek Behind the Scenes" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/08/animal-kingdom-poster-218x150.jpg" width="218" height="150" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Animal Kingdom" title="&#8216;Magic of Disney&#8217;s Animal Kingdom&#8217; Docuseries Offers a Peek Behind the Scenes" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/08/animal-kingdom-poster-218x150.jpg"  width="218" height="150" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.showbizjunkies.com/tv/magic-of-disney-animal-kingdom/" rel="bookmark" title="&#8216;Magic of Disney&#8217;s Animal Kingdom&#8217; Docuseries Offers a Peek Behind the Scenes">&#8216;Magic of Disney&#8217;s Animal Kingdom&#8217; Docuseries Offers a Peek Behind the Scenes</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.showbizjunkies.com/tv/one-of-us-is-lying-series/" rel="bookmark" class="td-image-wrap" title="&#8216;One of Us Is Lying&#8217; Mystery Drama Ordered to Series at Peacock"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" alt="One of Us Is Lying" title="&#8216;One of Us Is Lying&#8217; Mystery Drama Ordered to Series at Peacock" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/08/one-of-us-is-lying-218x150.jpg" width="218" height="150" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="One of Us Is Lying" title="&#8216;One of Us Is Lying&#8217; Mystery Drama Ordered to Series at Peacock" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/08/one-of-us-is-lying-218x150.jpg"  width="218" height="150" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.showbizjunkies.com/tv/one-of-us-is-lying-series/" rel="bookmark" title="&#8216;One of Us Is Lying&#8217; Mystery Drama Ordered to Series at Peacock">&#8216;One of Us Is Lying&#8217; Mystery Drama Ordered to Series at Peacock</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.showbizjunkies.com/tv/tough-as-nails-season-2-renewed/" rel="bookmark" class="td-image-wrap" title="&#8216;Tough as Nails&#8217; Will Stick Around for Season 2"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" alt="Tough As Nails" title="&#8216;Tough as Nails&#8217; Will Stick Around for Season 2" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/05/tough-as-nails-challengers-218x150.jpg" width="218" height="150" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Tough As Nails" title="&#8216;Tough as Nails&#8217; Will Stick Around for Season 2" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/05/tough-as-nails-challengers-218x150.jpg"  width="218" height="150" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.showbizjunkies.com/tv/tough-as-nails-season-2-renewed/" rel="bookmark" title="&#8216;Tough as Nails&#8217; Will Stick Around for Season 2">&#8216;Tough as Nails&#8217; Will Stick Around for Season 2</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_3_d00" data-td_block_id="tdi_3_d00"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_3_d00" data-td_block_id="tdi_3_d00"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><center>Advertisement</center><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="5119962385"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</aside> <aside class="td_block_template_1 widget widget_recent_entries"> <h4 class="block-title"><span>New Entertainment Articles</span></h4> <ul>
<li>
<a href="https://www.showbizjunkies.com/tv/magic-of-disney-animal-kingdom/">&#8216;Magic of Disney&#8217;s Animal Kingdom&#8217; Docuseries Offers a Peek Behind the Scenes</a>
</li>
<li>
<a href="https://www.showbizjunkies.com/tv/one-of-us-is-lying-series/">&#8216;One of Us Is Lying&#8217; Mystery Drama Ordered to Series at Peacock</a>
</li>
<li>
<a href="https://www.showbizjunkies.com/tv/sarah-cooper-everythings-fine/" aria-current="page">Sarah Cooper Gets Her Own Netflix Comedy Special</a>
</li>
<li>
<a href="https://www.showbizjunkies.com/tv/tough-as-nails-season-2-renewed/">&#8216;Tough as Nails&#8217; Will Stick Around for Season 2</a>
</li>
 <li>
<a href="https://www.showbizjunkies.com/tv/the-alienist-season-2-episode-8-recap/">&#8216;The Alienist&#8217; Season 2 Episode 8 Recap: &#8220;Better Angels&#8221; Finale</a>
</li>
</ul>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><center>Advertisement</center><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="8566409180"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</aside>
<aside class="td_block_template_1 widget popular-posts">
<div class="block-title"><span>Trending</span></div>

<div class="popular-posts-sr"><style>.wpp-tiles { margin-left: 0; margin-right: 0; padding: 0; } .wpp-tiles li { position: relative; list-style: none; margin: 0 0 1.2rem 0; padding: 0; } .wpp-tiles li:last-of-type { margin: 0; } .wpp-tiles li .wpp-thumbnail { overflow: hidden; display: block; margin: 0; width: 100%; height: auto; font-size: 0.8rem; line-height: 1; background: #f0f0f0; border: none; } .wpp-tiles li a { text-decoration: none; } .wpp-tiles li a:hover { text-decoration: underline; } .wpp-tiles li .wpp-post-data { position: absolute; left: 0; bottom: 0; padding: .75rem 1rem 1rem; width: 100%; box-sizing: border-box; background: rgba(0, 0, 0, 0.5); } .wpp-tiles li .wpp-post-data .category, .wpp-tiles li .wpp-post-data .wpp-post-title { color: #fff; font-weight: bold; } .wpp-tiles li .wpp-post-data .category { margin: 0; font-size: 0.7rem; line-height: 1; } .wpp-tiles li .wpp-post-data .wpp-post-title { display: block; margin: 0 0 0; font-size: 1rem; line-height: 1.2; }</style>
<ul class="wpp-list wpp-tiles">
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-8-recap/" target="_self"><img data-img-src="https://www.showbizjunkies.com/wp-content/uploads/wordpress-popular-posts/191902-featured-320x160.jpg" width="320" height="160" alt="Yellowstone Season 3 Episode 8" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a><div class="wpp-post-data"><a href="https://www.showbizjunkies.com/category/featured/" class="category category-1595">Featured</a>, <a href="https://www.showbizjunkies.com/category/tv/" class="category category-5">TV</a>, <a href="https://www.showbizjunkies.com/category/tv/tv-recaps/" class="category category-650">TV Show Recaps</a> <a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-8-recap/" class="wpp-post-title" target="_self">&#8216;Yellowstone&#8217; Season 3 Episode 8 Recap: &#8220;I Killed a Man Today&#8221;</a></div></li>
<li><a href="https://www.showbizjunkies.com/tv/the-alienist-season-2-episode-5-recap/" target="_self"><img data-img-src="https://www.showbizjunkies.com/wp-content/uploads/wordpress-popular-posts/191658-featured-320x160.jpg" width="320" height="160" alt="The Alienist Season 2 Episode 5" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a><div class="wpp-post-data"><a href="https://www.showbizjunkies.com/category/tv/" class="category category-5">TV</a>, <a href="https://www.showbizjunkies.com/category/tv/tv-recaps/" class="category category-650">TV Show Recaps</a> <a href="https://www.showbizjunkies.com/tv/the-alienist-season-2-episode-5-recap/" class="wpp-post-title" target="_self">&#8216;The Alienist&#8217; Season 2 Episode 5 Recap: &#8220;Belly of the Beast&#8221;</a></div></li>
<li><a href="https://www.showbizjunkies.com/tv/the-alienist-season-2-episode-6-recap/" target="_self"><img data-img-src="https://www.showbizjunkies.com/wp-content/uploads/wordpress-popular-posts/191675-featured-320x160.jpg" width="320" height="160" alt="The Alienist Season 2 Episode 6" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a><div class="wpp-post-data"><a href="https://www.showbizjunkies.com/category/tv/" class="category category-5">TV</a>, <a href="https://www.showbizjunkies.com/category/tv/tv-recaps/" class="category category-650">TV Show Recaps</a> <a href="https://www.showbizjunkies.com/tv/the-alienist-season-2-episode-6-recap/" class="wpp-post-title" target="_self">&#8216;The Alienist&#8217; Season 2 Episode 6 Recap: &#8220;Memento Mori&#8221;</a></div></li>
</ul>
</div>
</aside>
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><center>Advertisement</center><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-1475545870139320" data-ad-slot="5119962385"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</aside> </div>
</div>
</div> 
</div> 
</article> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-9 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Join the Showbiz Junkies Team</span></h4> <div class="textwidget"><p><a class="ftr-lnk" ; href="https://www.showbizjunkies.com/write-for-showbiz-junkies/">Write for Showbiz Junkies!</a></p>
</div>
</aside> </div>
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Contact Showbiz Junkies</span></h4> <div class="textwidget"><p><a href="http://showbizjunkies.com/contact-us/" class="ftr-lnk" ;>Contact Us</a></p>
<p><a href="https://www.showbizjunkies.com/showbiz-junkies-social-media/" class="ftr-lnk" ;>Follow Showbiz Junkies on Social Media</a></p>
<p>&nbsp;</p>
</div>
</aside> </div>
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>The Team and Terms and Conditions</span></h4> <div class="textwidget"><p><a href="https://www.showbizjunkies.com/about-us/" class="ftr-lnk" ;>About the Showbiz Junkies Team</a></p>
<p><a href="https://showbizjunkies.com/terms-and-conditions/" class="ftr-lnk" ;>Terms and Conditions</a></p>
</div>
</aside> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
All Rights Reserved – Showbiz Junkies 2020 </div>
</div>
</div>
</div>
</div>
</div>
 <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
<script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>


<style type="text/css" media="screen">
/* custom css theme panel */
.tdc-footer-wrap .widget a:hover {
  color: #E6E6FA;
}

.td-video-template-bg {background-color:#2d095c;}

.td-post-template-10 .td-post-featured-video { padding-bottom:10px;}
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.showbizjunkies.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=bb9c459bd63f43ae3fb9edbc59eb20c6'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=bb9c459bd63f43ae3fb9edbc59eb20c6'></script>

<script>
    
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.showbizjunkies.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
</body>
</html>
