<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>&#039;Yellowstone&#039; Season 3 Episode 5 Recap: &quot;Cowboys and Dreamers&quot;</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.showbizjunkies.com/xmlrpc.php" />
<link rel="icon" type="image/png" href="https://www.showbizjunkies.com/wp-content/uploads/2015/10/showbiz-favicon.jpg">

<title>&#039;Yellowstone&#039; Season 3 Episode 5 Recap: &quot;Cowboys and Dreamers&quot;</title>
<meta name="description" content="Recap of &#039;Yellowstone&#039; season 3 episode 5 airing July 19, 2020. We finally discover why Beth hates Jamie. Plus, Jamie takes the oath and Kayce confirms he cares about people." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;Yellowstone&#039; Season 3 Episode 5 Recap: &quot;Cowboys and Dreamers&quot;" />
<meta property="og:description" content="Recap of &#039;Yellowstone&#039; season 3 episode 5 airing July 19, 2020. We finally discover why Beth hates Jamie. Plus, Jamie takes the oath and Kayce confirms he cares about people." />
<meta property="og:url" content="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/" />
<meta property="og:site_name" content="ShowbizJunkies" />
<meta property="article:publisher" content="http://www.facebook.com/ShowbizJunkies" />
<meta property="article:published_time" content="2020-07-20T01:57:38+00:00" />
<meta property="article:modified_time" content="2020-07-19T16:47:02+00:00" />
<meta property="og:image" content="https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@https://www.twitter.com/becmur" />
<meta name="twitter:site" content="@becmur" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.showbizjunkies.com/#website","url":"https://www.showbizjunkies.com/","name":"ShowbizJunkies","description":"TV, Movies, Music, Celebs - We&#039;re Addicted to Entertainment","potentialAction":[{"@type":"SearchAction","target":"https://www.showbizjunkies.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/#primaryimage","inLanguage":"en-US","url":"https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5.jpg","width":1200,"height":800,"caption":"Cole Hauser and Kelly Reilly in 'Yellowstone' season 3 episode 5 (Photo Credit: Paramount Network)"},{"@type":"WebPage","@id":"https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/#webpage","url":"https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/","name":"'Yellowstone' Season 3 Episode 5 Recap: \"Cowboys and Dreamers\"","isPartOf":{"@id":"https://www.showbizjunkies.com/#website"},"primaryImageOfPage":{"@id":"https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/#primaryimage"},"datePublished":"2020-07-20T01:57:38+00:00","dateModified":"2020-07-19T16:47:02+00:00","author":{"@id":"https://www.showbizjunkies.com/#/schema/person/0093618f37a87a0b68144ab43884b762"},"description":"Recap of 'Yellowstone' season 3 episode 5 airing July 19, 2020. We finally discover why Beth hates Jamie. Plus, Jamie takes the oath and Kayce confirms he cares about people.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/"]}]},{"@type":["Person"],"@id":"https://www.showbizjunkies.com/#/schema/person/0093618f37a87a0b68144ab43884b762","name":"Rebecca Murray","image":{"@type":"ImageObject","@id":"https://www.showbizjunkies.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0443e1d61842b1a84eb14d933d36fcae?s=96&d=mm&r=pg","caption":"Rebecca Murray"},"description":"Journalist covering the entertainment industry for 21+ years, including 13 years as the first writer for About.com's Hollywood Movies site. Member of the Broadcast Television Journalists Association, Broadcast Film Critics Association, Alliance of Women Film Journalists, and President of the San Diego Film Critics Society.","sameAs":["https://twitter.com/https://www.twitter.com/becmur"]}]}</script>

<link rel="amphtml" href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/amp/" /><meta name="generator" content="AMP for WP 1.0.57" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="ShowbizJunkies &raquo; Feed" href="https://www.showbizjunkies.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ShowbizJunkies &raquo; Comments Feed" href="https://www.showbizjunkies.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ShowbizJunkies &raquo; &#8216;Yellowstone&#8217; Season 3 Episode 5 Recap: &#8220;Cowboys and Dreamers&#8221; Comments Feed" href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.showbizjunkies.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.showbizjunkies.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=db12099f894b3f53e301a89d22fdaaa5' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C300%7CRoboto%3A400%2C500%2C700%2C300&#038;display=swap&#038;ver=10.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.showbizjunkies.com/wp-content/themes/Newspaper/style.css?ver=10.3' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=db12099f894b3f53e301a89d22fdaaa5' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=d0cdd949f741c065e9b26cee76cd5ac2' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='https://www.showbizjunkies.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=bb9c459bd63f43ae3fb9edbc59eb20c6' type='text/css' media='all' />
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"100","ajax_url":"https:\/\/www.showbizjunkies.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"191017","token":"3f21ec5664","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script>
<link rel='https://api.w.org/' href='https://www.showbizjunkies.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.showbizjunkies.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.showbizjunkies.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.showbizjunkies.com/?p=191017' />

<link rel="stylesheet" href="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/css/jd.gallery.css.php" type="text/css" media="screen" charset="utf-8" />
<link rel="stylesheet" href="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/css/jd.gallery.css" type="text/css" media="screen" charset="utf-8" />
<script type="text/javascript" src="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/scripts/mootools.v1.11.js"></script>
<script type="text/javascript" src="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/scripts/jd.gallery.js.php"></script>
<script type="text/javascript" src="https://www.showbizjunkies.com/wp-content/plugins/featured-content-gallery/scripts/jd.gallery.transitions.js"></script>


<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"3f21ec5664","wpRestUrl":"https:\/\/www.showbizjunkies.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":20,"postAutoloadStatus":"on","origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.showbizjunkies.com\/wp-admin\/","wpRestNonce":"3f21ec5664","wpRestUrl":"https:\/\/www.showbizjunkies.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
<style type="text/css"></style>
<style type="text/css">
.synved-social-resolution-single {
display: inline-block;
}
.synved-social-resolution-normal {
display: inline-block;
}
.synved-social-resolution-hidef {
display: none;
}

@media only screen and (min--moz-device-pixel-ratio: 2),
only screen and (-o-min-device-pixel-ratio: 2/1),
only screen and (-webkit-min-device-pixel-ratio: 2),
only screen and (min-device-pixel-ratio: 2),
only screen and (min-resolution: 2dppx),
only screen and (min-resolution: 192dpi) {
	.synved-social-resolution-normal {
	display: none;
	}
	.synved-social-resolution-hidef {
	display: inline-block;
	}
}
</style>

<script>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</script>

<style>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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-24192790-1"></script>
<script>

  window.dataLayer = window.dataLayer || [];

  function gtag(){dataLayer.push(arguments);}

  gtag('js', new Date());

 

  gtag('config', 'UA-24192790-1');

</script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.showbizjunkies.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.showbizjunkies.com/category/tv/",
                    "name": "TV"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/",
                    "name": "&#8216;Yellowstone&#8217; Season 3 Episode 5 Recap: &#8220;Cowboys and Dreamers&#8221;"                                
                }
            }    
        ]
    }
</script>

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #6f2882;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #6f2882;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #6f2882;
                }
                .tdm-btn-style1 {
					background-color: #6f2882;
				}
				.tdm-btn-style2:before {
				    border-color: #6f2882;
				}
				.tdm-btn-style2 {
				    color: #6f2882;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #6f2882;
                    -moz-box-shadow: 0 2px 16px #6f2882;
                    box-shadow: 0 2px 16px #6f2882;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #6f2882;
                    -moz-box-shadow: 0 4px 26px #6f2882;
                    box-shadow: 0 4px 26px #6f2882;
				}
</style>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-191017 single-format-standard td-standard-pack yellowstone-season-3-episode-5-recap global-block-template-1 single_template_10 td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>

<div class="td-menu-login-section">
<div class="td-guest-wrap">
<div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
</div>
</div>

<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-155904" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-155904"><a href="https://www.showbizjunkies.com/">Home</a></li>
<li id="menu-item-229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-229"><a href="https://www.showbizjunkies.com/category/news/">Breaking News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-239" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li id="menu-item-241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-241"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li id="menu-item-242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-242"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li id="menu-item-243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243"><a href="https://www.showbizjunkies.com/category/news/celebrities-news/">Celebs News</a></li>
</ul>
</li>
<li id="menu-item-1583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1583"><a href="https://showbizjunkies.com/category/movies/">Movies<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1420"><a href="https://www.showbizjunkies.com/category/movies/movies-reviews/">Latest Movie Reviews</a></li>
<li id="menu-item-236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li id="menu-item-2042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2042"><a href="https://www.showbizjunkies.com/category/movies/trailers/">New Movie Trailers</a></li>
<li id="menu-item-237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li id="menu-item-137687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137687"><a href="https://www.showbizjunkies.com/category/movies/best-of-lists/">Best Of Lists</a></li>
<li id="menu-item-1421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1421"><a href="https://www.showbizjunkies.com/category/movies/movies-interviews/">Movie Interviews</a></li>
<li id="menu-item-1422" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1422"><a href="https://www.showbizjunkies.com/category/movies/movies-clips/">Film Clips</a></li>
</ul>
</li>
<li id="menu-item-226" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-226"><a href="https://www.showbizjunkies.com/category/tv/">TV<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1419" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1419"><a href="https://www.showbizjunkies.com/category/tv/tv-recaps/">TV Show Recaps</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://www.showbizjunkies.com/category/tv/clips/">TV Show Clips</a></li>
<li id="menu-item-233" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-233"><a href="https://www.showbizjunkies.com/category/tv/interviews/">TV Interviews</a></li>
<li id="menu-item-234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-234"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
</ul>
</li>
<li id="menu-item-225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-225"><a href="https://www.showbizjunkies.com/category/music/">Music<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li id="menu-item-245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li id="menu-item-246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-246"><a href="https://www.showbizjunkies.com/category/music/music-videos/">Music Videos</a></li>
<li id="menu-item-248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-248"><a href="https://www.showbizjunkies.com/category/music/artists/">Music Artists &#8211; Album Details, Biographies and News</a></li>
</ul>
</li>
<li id="menu-item-155903" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-155903"><a href="#">Gallery<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1426"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
<li id="menu-item-1425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1425"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li id="menu-item-250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li id="menu-item-251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
</ul>
</li>
<li id="menu-item-255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-255"><a href="https://www.showbizjunkies.com/category/celebrities/">Celebrity News and Photos<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-news/">Celeb News</a></li>
<li id="menu-item-253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-253"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
<li id="menu-item-1423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1423"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-videos/">Celeb Videos</a></li>
<li id="menu-item-105436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-105436"><a href="https://www.showbizjunkies.com/category/celebrities/celeb-interviews/">Celebrity Interviews &#8211; Actors, Writers and Directors</a></li>
<li id="menu-item-254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-info/">Celebrity Charities, Biographies, and Info</a></li>
<li id="menu-item-38296" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38296"><a href="https://www.showbizjunkies.com/category/celebrities/book-news/">Upcoming Book Releases and Book Reviews</a></li>
</ul>
</li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://www.showbizjunkies.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-1 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul></div>
<div class="td-header-sp-top-widget">
</div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.showbizjunkies.com/">
<img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" alt="Showbiz Junkies" title="Showbiz Junkies" />
<span class="td-visual-hidden">ShowbizJunkies</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_5a2 td_block_template_1 ">
<style>
/* custom css */
.tdi_1_5a2.td-a-rec-img{
				    text-align: left;
				}.tdi_1_5a2.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">Advertisement</span><ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="6714368657"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="https://www.showbizjunkies.com/">
<img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" alt="Showbiz Junkies" title="Showbiz Junkies" />
</a>
<a class="td-header-logo td-sticky-disable" href="https://www.showbizjunkies.com/">
<img class="td-retina-data" data-retina="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" src="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png" alt="Showbiz Junkies" title="Showbiz Junkies" />
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-155904"><a href="https://www.showbizjunkies.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-229"><a href="https://www.showbizjunkies.com/category/news/">Breaking News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-239"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-241"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-242"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-243"><a href="https://www.showbizjunkies.com/category/news/celebrities-news/">Celebs News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-1583"><a href="https://showbizjunkies.com/category/movies/">Movies</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1420"><a href="https://www.showbizjunkies.com/category/movies/movies-reviews/">Latest Movie Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-236"><a href="https://www.showbizjunkies.com/category/news/movie-news/">Movie News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2042"><a href="https://www.showbizjunkies.com/category/movies/trailers/">New Movie Trailers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-237"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-137687"><a href="https://www.showbizjunkies.com/category/movies/best-of-lists/">Best Of Lists</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1421"><a href="https://www.showbizjunkies.com/category/movies/movies-interviews/">Movie Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1422"><a href="https://www.showbizjunkies.com/category/movies/movies-clips/">Film Clips</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-226"><a href="https://www.showbizjunkies.com/category/tv/">TV</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-1419"><a href="https://www.showbizjunkies.com/category/tv/tv-recaps/">TV Show Recaps</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-231"><a href="https://www.showbizjunkies.com/category/news/tv-news/">TV News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-232"><a href="https://www.showbizjunkies.com/category/tv/clips/">TV Show Clips</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-233"><a href="https://www.showbizjunkies.com/category/tv/interviews/">TV Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-234"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-225"><a href="https://www.showbizjunkies.com/category/music/">Music</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-244"><a href="https://www.showbizjunkies.com/category/news/music-news/">Music News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-245"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-246"><a href="https://www.showbizjunkies.com/category/music/music-videos/">Music Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-248"><a href="https://www.showbizjunkies.com/category/music/artists/">Music Artists &#8211; Album Details, Biographies and News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-155903"><a href="#">Gallery</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1426"><a href="https://www.showbizjunkies.com/category/tv/tv-photos/">TV Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1425"><a href="https://www.showbizjunkies.com/category/music/music-photos/">Music Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-250"><a href="https://www.showbizjunkies.com/category/movies/movie-photos/">Film Photos and Posters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-251"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-255"><a href="https://www.showbizjunkies.com/category/celebrities/">Celebrity News and Photos</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-252"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-news/">Celeb News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-253"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-photos/">Celeb Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1423"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-videos/">Celeb Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-105436"><a href="https://www.showbizjunkies.com/category/celebrities/celeb-interviews/">Celebrity Interviews &#8211; Actors, Writers and Directors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-254"><a href="https://www.showbizjunkies.com/category/celebrities/celebrity-info/">Celebrity Charities, Biographies, and Info</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38296"><a href="https://www.showbizjunkies.com/category/celebrities/book-news/">Upcoming Book Releases and Book Reviews</a></li>
</ul>
</li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.showbizjunkies.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<article id="post-191017" class="td-post-template-10 post-191017 post type-post status-publish format-standard has-post-thumbnail category-tv category-tv-recaps tag-cole-hauser tag-episode tag-josh-holloway tag-kelly-reilly-2 tag-kevin-costner tag-luke-grimes tag-recap tag-wes-bentley tag-yellowstone td-container-wrap" itemscope itemtype="https://schema.org/Article">
<div class="td-video-template-bg">
<div class="td-container">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.showbizjunkies.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in TV" class="entry-crumb" href="https://www.showbizjunkies.com/category/tv/">TV</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">&#8216;Yellowstone&#8217; Season 3 Episode 5 Recap: &#8220;Cowboys and Dreamers&#8221;</span></div></div>
<div class="td-post-featured-video">
</div>
</div>
</div>
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://www.showbizjunkies.com/category/tv/">TV</a></li><li class="entry-category"><a href="https://www.showbizjunkies.com/category/tv/tv-recaps/">TV Show Recaps</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">&#8216;Yellowstone&#8217; Season 3 Episode 5 Recap: &#8220;Cowboys and Dreamers&#8221;</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.showbizjunkies.com/author/admin/">Rebecca Murray</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date">July 19, 2020</time></span> </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fyellowstone-season-3-episode-5-recap%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98Yellowstone%E2%80%99+Season+3+Episode+5+Recap%3A+%E2%80%9CCowboys+and+Dreamers%E2%80%9D&url=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fyellowstone-season-3-episode-5-recap%2F&via=ShowbizJunkies">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/&amp;media=https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5.jpg&description=Recap of &#039;Yellowstone&#039; season 3 episode 5 airing July 19, 2020. We finally discover why Beth hates Jamie. Plus, Jamie takes the oath and Kayce confirms he cares about people.">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=%E2%80%98Yellowstone%E2%80%99+Season+3+Episode+5+Recap%3A+%E2%80%9CCowboys+and+Dreamers%E2%80%9D %0A%0A https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<figure id="attachment_191028" aria-describedby="caption-attachment-191028" style="width: 580px" class="wp-caption aligncenter"><img src="https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5-580x387.jpg" alt="Yellowstone Season 3 Episode 5" width="580" height="387" class="size-large wp-image-191028" srcset="https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5-580x387.jpg 580w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5-300x200.jpg 300w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5-768x512.jpg 768w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5-696x464.jpg 696w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5-1068x712.jpg 1068w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5-630x420.jpg 630w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5.jpg 1200w" sizes="(max-width: 580px) 100vw, 580px" /><figcaption id="caption-attachment-191028" class="wp-caption-text">Cole Hauser and Kelly Reilly in &#8216;Yellowstone&#8217; season 3 episode 5 (Photo Credit: Paramount Network)</figcaption></figure>
<p>Season three episode five of Paramount Network’s <a href="https://www.showbizjunkies.com/tag/yellowstone/"><em>Yellowstone</em></a> begins with a flashback. A teenage Beth turns to her brother Jamie for help after discovering she’s pregnant. As they drive to the reservation, Beth refuses to tell Jamie the name of the father. They arrive at Indian Health Services and Beth reaches out to take hold of Jamie’s hand. He volunteers to go inside and find out what to do next.</p>
<p>Jamie called in before showing up, but the woman manning the desk is shocked to see he&#8217;s white. Jamie and Beth deliberately chose the Indian Health Services knowing that if they went to Planned Parenthood in town, someone might see them and the word would get out. She explains they require anyone having an abortion at the Indian clinic to also undergo sterilization.</p>
<p>After two and a half seasons, the explanation for Beth’s hatred of her brother is revealed. Jamie returns to the truck to fetch Beth but doesn’t immediately tell her about the sterilization requirement! Does he tell her after they enter the clinic? That’s not shown. If not, how does he live with himself after making that decision for his younger sister?</p>
<p>Later, Beth meets up with the boy who got her pregnant who, it turns out, is Rip. She lies and says the test was negative, and then breaks things off with him.</p>
<p>Back to current events and Beth (<a href="https://www.showbizjunkies.com/tag/kelly-reilly-2/">Kelly Reilly</a>) rises from Rip’s bed in the middle of the night. Rip (<a href="https://www.showbizjunkies.com/tag/cole-hauser/">Cole Hauser</a>) also gets up and joins her on the front porch. She confesses she had a bad dream/bad memory but doesn’t want to explain what it was about when he asks. He suggests she tell him anyway and she says, “I’ve made two decisions in my life based on fear…and they cost me everything.”</p>
<p>Beth leans into Rip and he kisses her on the head. As she quietly cries, Rip replies, “Not everything.” (When <em>Yellowstone</em> comes to an end, I want a Rip and Beth spinoff.)</p>
<p>Jamie (<a href="https://www.showbizjunkies.com/tag/wes-bentley/">Wes Bentley</a>) takes the oath of Attorney General as John looks on, uninvolved and unimpressed. As Jamie finishes reciting the oath, John commands his son to repeat the final line of the oath: “I will discharge the duties of my office with fidelity, so help me God.”</p>
<p>Jamie does, but leaves off “So help me God” and John makes him add that again. Brief ceremony complete, John leaves but not before reminding Governor Perry (Wendy Moniz-Grillo) Jamie’s all hers now. The retiring AG promises to help with the transition before hitting the golf course.</p>
<p>Jamie acknowledges he realizes he’s the AG now not at his father’s urging but because Governor Perry needed him for a specific task.</p>
<p>Rancher Boyd Nelson drives out to the field where a herd of horses are grazing. He withdraws a paper from his pocket and glances at it before putting a gun to his temple and pulling the trigger.</p>
<p>Kayce (<a href="https://www.showbizjunkies.com/tag/luke-grimes/">Luke Grimes</a>) is in the office as the new Livestock Commissioner when he receives a call from Sheriff Haskell (Hugh Dillon) informing him of Boyd’s death. Haskell won’t explain why it’s a matter for the Livestock Commissioner but instead just asks Kayce to head out to Boyd’s ranch.</p>
<p>Once there, Haskell hands Kayce the blood-stained paper Boyd was holding onto when he committed suicide. The paper is a formal Notice of Intent to Foreclose document. Kayce feels horrible, knowing Boyd has kids he left behind. Kayce and Haskell realize the bank will take the horses as part of the foreclosure, and Kayce suggests they round them up and take them to Billings for sale. If the horses aren’t on the property, the bank can’t get them.</p>
<p>Kayce wants to sell the horses to get money for Boyd’s kids, but he’s not sure taking them is legal. Haskell assures him it’s not. Still, Kayce&#8217;s leaning toward doing it anyway. He asks what Haskell would think if he did, and Haskell reveals Boyd was cousin.</p>
<p>“If you want to do it, I’ll look away,” says Haskell. “But if the bank finds out, you are up to your neck in trouble.”</p>
<p>Kayce decides the best option is to talk to his dad before doing anything.</p>
<p>Meanwhile, Monica (Kelsey Asbille) and Tate (Brecken Merrill) help the wranglers pack up their stuff. They have to move back to the house now that Kayce’s got a job to do in town, and Tate’s not in the least bit happy about that. He cusses and Monica wonders where he picked that up. The answer comes quickly as the nearby wranglers drop plenty of colorful words.</p>
<p>Monica asks Rip to have the guys leave their tent up, hoping to get Tate up there during the summer. Rip assures her he’ll have them keep it up.</p>
<p>Rip takes off with Ryan (Ian Bohen) and Colby (Denim Richards) to check on the fence line as the rest of the wranglers bring the horses back to the main part of the ranch.</p>
<figure id="attachment_191029" aria-describedby="caption-attachment-191029" style="width: 580px" class="wp-caption aligncenter"><img src="https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b-580x387.jpg" alt="Yellowstone Season 3 Episode 5" width="580" height="387" class="size-large wp-image-191029" srcset="https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b-580x387.jpg 580w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b-300x200.jpg 300w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b-768x512.jpg 768w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b-696x464.jpg 696w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b-1068x712.jpg 1068w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b-630x420.jpg 630w, https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5b.jpg 1200w" sizes="(max-width: 580px) 100vw, 580px" /><figcaption id="caption-attachment-191029" class="wp-caption-text">Gil Birmingham, Mo Brings Plenty, and Kevin Costner in &#8216;Yellowstone&#8217; season 3 episode 5 (Photo Credit: Paramount Network)</figcaption></figure>
<p>John’s back at the ranch when Thomas Rainwater (Gil Birmingham) and Mo (Mo Brings Plenty) arrive. Thomas jokes about how hard it’s been to reach John, and John assures him he’s been neglecting his phone on purpose. Lighter moments aside, Thomas wants to discuss their mutual problem.</p>
<p>Thomas knows John’s aware Ellis’ people want to use part of the Dutton Ranch for their airport. John reveals the A.G. would be the one who determines eminent domain and he’s not worried about the A.G. going against him now. He’s also not worried about the possibility Governor Perry will side with the developers.</p>
<p>Thomas believes if Governor Perry doesn’t help Ellis, she’ll lose the next election. John wonders why Thomas isn’t supporting an airport on the Yellowstone Ranch given its proximity to his planned second casino. Thomas sets John straight, acknowledging he doesn’t want a second casino and revealing he believes it’s an insulting revenue stream for an Indian Nation.</p>
<p>Thomas wants the valley to look like it did before white men arrived. He explains he and John want the same thing – they just have different reasons for wanting Ellis not to succeed. Thomas thinks he and John should postpone their fight and tackle this mutual enemy together. He suggests they pool their resources and make it so the corporation will eventually choose another place to build rather than be tied up in court for years. Corporations have money and manpower but don’t have time.</p>
<p>Thomas explains he’s got someone who can find items to help tie up the corporation in court. John says he has one of those people, too. Thomas was aware of that and thinks these two should meet. “Who knows what mischief they’ll come up with together,” says Thomas. John agrees.</p>
<p>Meanwhile, Roarke (<a href="https://www.showbizjunkies.com/tag/josh-holloway/">Josh Holloway</a>) is studying the market on his laptops and orders his person to snap up 300,000 at $1.35. “Short our f**king stock,” he snarls. “Take that you little red-headed sh*t.”</p>
<p>Trade done, he heads off to fish. Unfortunately, he’s barely out the front door with rod in hand when he gets a call telling him Market Equities has lost another point. He slams the fishing pole to the ground in anger and frustration. He storms back into the house, fishing no longer an option at this particular moment.</p>
<p>Rip, Colby, and Ryan discover buffalo in a field adjacent to theirs. They also spot two men on horses nearby. Rip beckons them to come to the fence and they meander over. Rip’s concerned the buffalo are going to spook the Dutton Ranch’s cattle, and one of the men suggests Rip just worry about keeping his cows on his side of the fence. Basically, he&#8217;s telling Rip to mind his own business.</p>
<p>It’s never wise to snap at Rip, and Rip challenges the man who was rude. The man hops the fence to confront Rip, and Rip punches him in the face before tossing him back over the fence. The other man takes that opportunity to pull a gun on Rip. He threatens to blow his face off and Rip tells him to just do it. (That seems to be Rip&#8217;s standard reply when facing a loaded gun.) The man doesn’t back down and Ryan jumps into the fray, displaying his Livestock Association badge and warning the man he’ll shoot him where he stands. Ryan tells him to put his gun down and the man suggests they tell John Dutton hi for him, revealing his name is Wade Morrow. He also warns they’ll see each other again.</p>
<p>After the men leave, Colby says he thinks the buffalo will tear the fence to pieces.</p>
<p>Roarke meets up with Beth at a bar. She wonders why he’s not in a river fishing and he explains he’s there to determine why she’s “poking a grizzly.” He compares Schwartz &#038; Meyer shorting Market Equities stock to a terrorist attack. It won’t stop anything and only serves to hurt some people while others will be prompted to hurt them back. Beth tells Roarke to bring it on; she’s a veteran in this battle over her family’s ranch and no one has gotten the best of her yet.</p>
<p>He suggests eventually the Duttons will lose the land. It’s better to not fight and become extremely wealthy now, rather than let the land eventually slip away. He believes Beth should act like the smart businesswoman she is and strike a deal.</p>
<p>Beth admits she agrees with his reasoning, but her dad would never agree so they have to fight.</p>
<p>She does, however, agree to his request to only short his stock in after-hours trading from now on so that he can spend his days torturing trout. (He’s a catch-and-release kind of guy.)</p>
<p>Before he leaves, Roarke warns Beth she’s wrong if she thinks she’s up to this fight. Beth replies, “Right back atcha. You are the trailer park; I am the tornado.”</p>
<p>Later, Kayce meets with his dad to discuss Boyd. John describes Boyd as a dreamer who became an angry man. Kayce explains what he wants to do and John agrees, saying Boyd’s wife is a good person who Boyd didn’t deserve. When Kayce points out the risk if the bank finds out, John has the perfect reply.</p>
<p>“The bank’s not your problem. Your problem’s the people. Do what’s best for them – that’s the job,” suggests John.</p>
<p>John says once Kayce makes the decision, he’ll help him however he needs.</p>
<p>Kayce decides to help the family and John gathers wranglers from his ranch and another nearby to round up the horses. There’s so many of them all they can really hope is to drive them down the mountain as fast as possible. Rip labels their approach the “F**K It” plan.</p>
<p>The wranglers all head out and pretty quickly the horses stream down the mountain with the men hot on their heels. They’re a thing of beauty to behold as they cross fields with the wranglers close behind.</p>
<p>The horses are lead into the corrals with minimal trouble. Apparently, the “F**k It” plan worked perfectly. Kayce, Rip, and John laugh about what they just did, and John had such an exhilarating time he wants to do it all over again.</p>
<p>Jamie rings up Randy Harper (K.C. Clyde) to let him know he’s the new A.G. and ask if he has any unresolved issues he’d like to discuss. Randy&#8217;s shocked and says he can’t think of any, now aware they have nothing to worry about when it comes to the deaths of the two suspects while in custody. (And the subsequent lies they told to bury the truth.)</p>
<p>The horses are delivered to the auction house without incident. Kayce wants to sell them as a pack and the man in charge confirms he can easily do just that.</p>
<p>Kayce returns to the Nelson ranch to speak with Boyd’s wife. There’s a large gathering of people there to mourn Boyd and support the family. Kayce’s ushered through the house and into the kitchen where Sheriff Haskell introduces him to Carolyn Nelson. She gives Kayce a huge hug and then asks what he got for the horses. Kayce reveals he hoped to get more but was able to sell them for $16,000. He hopes that helps with the funeral, and Carolyn confesses she’s not having a funeral for her dead husband. She thinks he took the coward’s way out.</p>
<p>Jimmy (Jefferson White) is released from the hospital and arrives back at the bunkhouse accompanied by his girlfriend, Mia (Eden Brolin), and her friend, Laramie (Hassie Harrison). They grab beers from the fridge, and Jimmy warns them the wranglers won’t like that. They don&#8217;t care.</p>
<p>They’re playing music and dancing as the wranglers arrive, and Jimmy tries to tell the guys it’s not his fault. Fortunately, they’re all in good spirits and ready to party themselves, given that it’s Friday night.</p>
<p>Ryan gives Colby a hard time about Teeter who continues to tease Colby about the fact they’ve had sex. Colby, reluctantly, admits she&#8217;s sort of growing on him.</p>
<p>Rip’s in a rotten mood and hearing the music from the bunkhouse isn’t improving it any. He’s pissed it’s not even sunset and they’re already drinking. Rip heads over to the bunkhouse where everyone’s having a fun time and as he enters he growls, “What the f**k are you dipshits doing?!”</p>
<p>Only then does he realize one of the dipshits is Beth. She’s dancing, drinking, and having a good time. He joins her, a smile finally coming to his face as they kiss.</p>
<p>John chuckles, sitting outside the house as he listens to the music. Kayce joins him and John’s happy the wranglers are cutting loose after the day they had. He compliments Kayce on breaking a rule that shouldn’t have existed, acknowledging he did it for the right reasons.</p>
<p>Kayce wonders if they should head over and join the fun, and John admits he can’t. “I never had much luck leading men <em>and</em> being their friend,” he says. He hopes it can be different for Kayce.</p>
<p>John heads into bed and Kayce takes his place in the chair on the porch.</p>
<ul>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-review/"><em>Yellowstone</em> Series Review</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-1-episode-2-recap/">Recap of Season 1 Episode 2 &#8220;Kill the Messenger&#8221;</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-1-episode-3-recap/">Recap of Season 1 Episode 3 &#8220;No Good Horses&#8221;</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-1-episode-4-recap/">Recap of Season 1 Episode 4 &#8220;The Long Black Train&#8221;</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-1-episode-6-recap/">Recap of Season 1 Episode 6 &#8220;The Remembering&#8221;</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-1-episode-7-recap/">Recap of Season 1 Episode 7 &#8220;A Monster Among Us&#8221;</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-1-episode-8-recap/">Recap of Season 1 Episode 8 &#8220;The Unravelling: Part 1&#8221;</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-1-episode-9-recap/"><em>Yellowstone</em> Season 1 Finale Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-1-recap/"><em>Yellowstone</em> Season 2 Episode 1 &#8220;A Thundering&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-2-recap/"><em>Yellowstone</em> Season 2 Episode 2 &#8220;New Beginnings&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-3-recap/"><em>Yellowstone</em> Season 2 Episode 3 &#8220;The Reek of Desperation&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season2-episode-4/"><em>Yellowstone</em> Season 2 Episode 4 &#8220;Only Devils Left&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-6-recap-blood-the-boy/"><em>Yellowstone</em> Season 2 Episode 6 &#8220;Blood the Boy&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-7-recap/"><em>Yellowstone</em> Season 2 Episode 7 &#8220;Resurrection Day&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-8-recap/"><em>Yellowstone</em> Season 2 Episode 8 &#8220;Behind Us Only Grey&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-9-recap/"><em>Yellowstone</em> Season 2 Episode 9 &#8220;Enemies By Monday&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-2-episode-10-recap/"><em>Yellowstone</em> Season 2 Episode 10 &#8220;Sins of the Father&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-1-recap/"><em>Yellowstone</em> Season 3 Episode 1 &#8220;You&#8217;re the Indian Now&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-2-recap/"><em>Yellowstone</em> Season 3 Episode 2 &#8220;Freight Trains and Monsters&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-3-recap/"><em>Yellowstone</em> Season 3 Episode 3 &#8220;An Acceptable Surrender&#8221; Recap</a></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-4-recap/"><em>Yellowstone</em> Season 3 Episode 4 &#8220;Going Back to Cali&#8221; Recap</a></li>
</ul>
<p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1475545870139320" data-ad-slot="7338398786" data-ad-format="autorelaxed"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<div id="amzn-assoc-ad-8664f0e8-95e2-484c-b072-743908c85ff3"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=8664f0e8-95e2-484c-b072-743908c85ff3"></script></div>

</div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.showbizjunkies.com/tag/cole-hauser/">cole hauser</a></li><li><a href="https://www.showbizjunkies.com/tag/episode/">episode</a></li><li><a href="https://www.showbizjunkies.com/tag/josh-holloway/">josh holloway</a></li><li><a href="https://www.showbizjunkies.com/tag/kelly-reilly-2/">kelly reilly</a></li><li><a href="https://www.showbizjunkies.com/tag/kevin-costner/">kevin costner</a></li><li><a href="https://www.showbizjunkies.com/tag/luke-grimes/">luke grimes</a></li><li><a href="https://www.showbizjunkies.com/tag/recap/">recap</a></li><li><a href="https://www.showbizjunkies.com/tag/wes-bentley/">wes bentley</a></li><li><a href="https://www.showbizjunkies.com/tag/yellowstone/">yellowstone</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fyellowstone-season-3-episode-5-recap%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98Yellowstone%E2%80%99+Season+3+Episode+5+Recap%3A+%E2%80%9CCowboys+and+Dreamers%E2%80%9D&url=https%3A%2F%2Fwww.showbizjunkies.com%2Ftv%2Fyellowstone-season-3-episode-5-recap%2F&via=ShowbizJunkies">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/&amp;media=https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5.jpg&description=Recap of &#039;Yellowstone&#039; season 3 episode 5 airing July 19, 2020. We finally discover why Beth hates Jamie. Plus, Jamie takes the oath and Kayce confirms he cares about people.">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=%E2%80%98Yellowstone%E2%80%99+Season+3+Episode+5+Recap%3A+%E2%80%9CCowboys+and+Dreamers%E2%80%9D %0A%0A https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.showbizjunkies.com/music/the-chicks-gaslighter-album/">The Chicks Release &#8216;Gaslighter,&#8217; Their First New Album in 14 Years</a></div></div><div class="td-next-prev-separator"></div></div> <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.showbizjunkies.com/author/admin/">Rebecca Murray</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Rebecca Murray"></span><meta itemprop="datePublished" content="2020-07-19T21:57:38-04:00"><meta itemprop="dateModified" content="2020-07-19T12:47:02-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.showbizjunkies.com/wp-content/uploads/2015/10/ShowbizJunkieD17aR02aP01ZL-Polk2a.png"></span><meta itemprop="name" content="ShowbizJunkies"></span><meta itemprop="headline " content="&#039;Yellowstone&#039; Season 3 Episode 5 Recap: &quot;Cowboys and Dreamers&quot;"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.showbizjunkies.com/wp-content/uploads/2020/07/yellowstone-season3-episode5.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="800"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_3_1ff td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_3_1ff"><script>var block_tdi_3_1ff = new tdBlock();
block_tdi_3_1ff.id = "tdi_3_1ff";
block_tdi_3_1ff.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3_1ff","td_column_number":3,"live_filter_cur_post_id":191017,"live_filter_cur_post_author":"1","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3_1ff","tdc_css_class_style":"tdi_3_1ff_rand_style"}';
block_tdi_3_1ff.td_column_number = "3";
block_tdi_3_1ff.block_type = "td_block_related_posts";
block_tdi_3_1ff.post_count = "3";
block_tdi_3_1ff.found_posts = "6264";
block_tdi_3_1ff.header_color = "";
block_tdi_3_1ff.ajax_pagination_infinite_stop = "";
block_tdi_3_1ff.max_num_pages = "2088";
tdBlocksArray.push(block_tdi_3_1ff);
</script><h4 class="td-related-title td-block-title"><a id="tdi_4_977" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3_1ff" href="#">RELATED ARTICLES</a><a id="tdi_5_fac" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3_1ff" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3_1ff class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.showbizjunkies.com/tv/agents-of-shield-season-7-episode-9/" rel="bookmark" class="td-image-wrap" title="&#8216;Agents of S.H.I.E.L.D.&#8217; Season 7 Episode 9 Photos: Preview of &#8220;As I Have Always Been&#8221;"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Agents of Shield Season 7 Episode 9" title="&#8216;Agents of S.H.I.E.L.D.&#8217; Season 7 Episode 9 Photos: Preview of &#8220;As I Have Always Been&#8221;" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/07/agents-of-shield-season7-episode9-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.showbizjunkies.com/tv/agents-of-shield-season-7-episode-9/" rel="bookmark" title="&#8216;Agents of S.H.I.E.L.D.&#8217; Season 7 Episode 9 Photos: Preview of &#8220;As I Have Always Been&#8221;">&#8216;Agents of S.H.I.E.L.D.&#8217; Season 7 Episode 9 Photos: Preview of &#8220;As I Have Always Been&#8221;</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.showbizjunkies.com/tv/ava-duvernay-home-sweet-home/" rel="bookmark" class="td-image-wrap" title="Ava DuVernay&#8217;s &#8216;Home Sweet Home&#8217; Unscripted Series Greenlit at NBC"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Ava DuVernay" title="Ava DuVernay&#8217;s &#8216;Home Sweet Home&#8217; Unscripted Series Greenlit at NBC" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/07/ava-duvernay-home-sweet-home-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.showbizjunkies.com/tv/ava-duvernay-home-sweet-home/" rel="bookmark" title="Ava DuVernay&#8217;s &#8216;Home Sweet Home&#8217; Unscripted Series Greenlit at NBC">Ava DuVernay&#8217;s &#8216;Home Sweet Home&#8217; Unscripted Series Greenlit at NBC</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.showbizjunkies.com/tv/bulletproof-season-2-episode-7/" rel="bookmark" class="td-image-wrap" title="&#8216;Bulletproof&#8217; Season 2 Episode 7 Preview: Photos and Plot Description"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Bulletproof Season 2 Episode 7" title="&#8216;Bulletproof&#8217; Season 2 Episode 7 Preview: Photos and Plot Description" data-type="image_tag" data-img-url="https://www.showbizjunkies.com/wp-content/uploads/2020/07/bulletproof-season2-episode7b-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.showbizjunkies.com/tv/bulletproof-season-2-episode-7/" rel="bookmark" title="&#8216;Bulletproof&#8217; Season 2 Episode 7 Preview: Photos and Plot Description">&#8216;Bulletproof&#8217; Season 2 Episode 7 Preview: Photos and Plot Description</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_3_1ff" data-td_block_id="tdi_3_1ff"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_3_1ff" data-td_block_id="tdi_3_1ff"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><center>Advertisement</center><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="5119962385"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</aside> <aside class="td_block_template_1 widget widget_recent_entries"> <h4 class="block-title"><span>New Entertainment Articles</span></h4> <ul>
<li>
<a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-5-recap/" aria-current="page">&#8216;Yellowstone&#8217; Season 3 Episode 5 Recap: &#8220;Cowboys and Dreamers&#8221;</a>
</li>
<li>
<a href="https://www.showbizjunkies.com/music/the-chicks-gaslighter-album/">The Chicks Release &#8216;Gaslighter,&#8217; Their First New Album in 14 Years</a>
</li>
<li>
<a href="https://www.showbizjunkies.com/tv/agents-of-shield-season-7-episode-9/">&#8216;Agents of S.H.I.E.L.D.&#8217; Season 7 Episode 9 Photos: Preview of &#8220;As I Have Always Been&#8221;</a>
</li>
<li>
<a href="https://www.showbizjunkies.com/tv/ava-duvernay-home-sweet-home/">Ava DuVernay&#8217;s &#8216;Home Sweet Home&#8217; Unscripted Series Greenlit at NBC</a>
</li>
<li>
<a href="https://www.showbizjunkies.com/news/the-old-guard-game-immortal-netflix-account/">&#8216;The Old Guard&#8217; Game Could Land You an *Immortal* Netflix Account</a>
</li>
</ul>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><center>Advertisement</center><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-1475545870139320" data-ad-slot="8566409180"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</aside>
<aside class="td_block_template_1 widget popular-posts">
<div class="block-title"><span>Trending</span></div>

<div class="popular-posts-sr"><style>.wpp-tiles { margin-left: 0; margin-right: 0; padding: 0; } .wpp-tiles li { position: relative; list-style: none; margin: 0 0 1.2rem 0; padding: 0; } .wpp-tiles li:last-of-type { margin: 0; } .wpp-tiles li .wpp-thumbnail { overflow: hidden; display: block; margin: 0; width: 100%; height: auto; font-size: 0.8rem; line-height: 1; background: #f0f0f0; border: none; } .wpp-tiles li a { text-decoration: none; } .wpp-tiles li a:hover { text-decoration: underline; } .wpp-tiles li .wpp-post-data { position: absolute; left: 0; bottom: 0; padding: .75rem 1rem 1rem; width: 100%; box-sizing: border-box; background: rgba(0, 0, 0, 0.5); } .wpp-tiles li .wpp-post-data .category, .wpp-tiles li .wpp-post-data .wpp-post-title { color: #fff; font-weight: bold; } .wpp-tiles li .wpp-post-data .category { margin: 0; font-size: 0.7rem; line-height: 1; } .wpp-tiles li .wpp-post-data .wpp-post-title { display: block; margin: 0 0 0; font-size: 1rem; line-height: 1.2; }</style>
<ul class="wpp-list wpp-tiles">
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-4-recap/" target="_self"><img data-img-src="https://www.showbizjunkies.com/wp-content/uploads/wordpress-popular-posts/190727-featured-320x160.jpg" width="320" height="160" alt="Yellowstone Season 3 Episode 4" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a><div class="wpp-post-data"><a href="https://www.showbizjunkies.com/category/tv/" class="category category-5">TV</a>, <a href="https://www.showbizjunkies.com/category/tv/tv-recaps/" class="category category-650">TV Show Recaps</a> <a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-4-recap/" class="wpp-post-title" target="_self">&#8216;Yellowstone&#8217; Season 3 Episode 4 Recap: &#8220;Going Back to Cali&#8221;</a></div></li>
<li><a href="https://www.showbizjunkies.com/tv/perry-mason-season-1-episodes-finale/" target="_self"><img data-img-src="https://www.showbizjunkies.com/wp-content/uploads/wordpress-popular-posts/190780-featured-320x160.jpg" width="320" height="160" alt="Perry Mason Season 1" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a><div class="wpp-post-data"><a href="https://www.showbizjunkies.com/category/news/" class="category category-7">Breaking News</a>, <a href="https://www.showbizjunkies.com/category/tv/shows/" class="category category-13">Shows</a>, <a href="https://www.showbizjunkies.com/category/tv/" class="category category-5">TV</a>, <a href="https://www.showbizjunkies.com/category/news/tv-news/" class="category category-9">TV News</a> <a href="https://www.showbizjunkies.com/tv/perry-mason-season-1-episodes-finale/" class="wpp-post-title" target="_self">&#8216;Perry Mason&#8217; Season 1 Episode Guide: Details on Episodes 5 &#8211; 8</a></div></li>
<li><a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-3-recap/" target="_self"><img data-img-src="https://www.showbizjunkies.com/wp-content/uploads/wordpress-popular-posts/190427-featured-320x160.jpg" width="320" height="160" alt="Yellowstone Season 3 Episode 3" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a><div class="wpp-post-data"><a href="https://www.showbizjunkies.com/category/tv/" class="category category-5">TV</a>, <a href="https://www.showbizjunkies.com/category/tv/tv-recaps/" class="category category-650">TV Show Recaps</a> <a href="https://www.showbizjunkies.com/tv/yellowstone-season-3-episode-3-recap/" class="wpp-post-title" target="_self">&#8216;Yellowstone&#8217; Season 3 Episode 3 Recap: &#8220;An Acceptable Surrender&#8221;</a></div></li>
</ul>
</div>
</aside>
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><center>Advertisement</center><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-1475545870139320" data-ad-slot="5119962385"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</aside> </div>
</div>
</div> 
</div> 
</article> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-9 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Join the Showbiz Junkies Team</span></h4> <div class="textwidget"><p><a class="ftr-lnk" ; href="https://www.showbizjunkies.com/write-for-showbiz-junkies/">Write for Showbiz Junkies!</a></p>
</div>
</aside> </div>
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Contact Showbiz Junkies</span></h4> <div class="textwidget"><p><a href="http://showbizjunkies.com/contact-us/" class="ftr-lnk" ;>Contact Us</a></p>
<p><a href="https://www.showbizjunkies.com/showbiz-junkies-social-media/" class="ftr-lnk" ;>Follow Showbiz Junkies on Social Media</a></p>
<p>&nbsp;</p>
</div>
</aside> </div>
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>The Team and Terms and Conditions</span></h4> <div class="textwidget"><p><a href="https://www.showbizjunkies.com/about-us/" class="ftr-lnk" ;>About the Showbiz Junkies Team</a></p>
<p><a href="https://showbizjunkies.com/terms-and-conditions/" class="ftr-lnk" ;>Terms and Conditions</a></p>
</div>
</aside> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
All Rights Reserved – Showbiz Junkies 2020 </div>
</div>
</div>
</div>
</div>
</div>
 <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
<script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>


<style type="text/css" media="screen">
/* custom css theme panel */
.tdc-footer-wrap .widget a:hover {
  color: #E6E6FA;
}

.td-video-template-bg {background-color:#2d095c;}

.td-post-template-10 .td-post-featured-video { padding-bottom:10px;}
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.showbizjunkies.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=bb9c459bd63f43ae3fb9edbc59eb20c6'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.showbizjunkies.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=bb9c459bd63f43ae3fb9edbc59eb20c6'></script>

<script>
    
</script>
</body>
</html>